Issue with J3.7b3 testing my component

Issue with J3.7b3 testing my component

4 Jahre 1 Woche her - 4 Jahre 1 Woche her #1518 von Ruud van Lent

Hi, just a heads-up.
ran into an issue with my component under Joomla 3.7 (beta3).

the issue is as follows:
component-creator generates two helper files for the component: one in the administrator/helpers and one in site/helpers.
Problem is that bot helpers have the same class name eg: class MycomponentHelpersMycomponent

Now where does this go wrong:
It turns out that the new fields functionality (plg_system_fields) autoloads the helper classes and crashes my site with a Cannot redeclare class MycomponentHelpersMycomponent
e.g. when calling contenplugins in the component.

This is not correct. Two classes should never have the same class name :)

hope this helps :)

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

4 Jahre 1 Woche her #1521 von Andres Maeso

Hi Rud!

Thank you very much for the heads-up! We really appreciate feedback like yours. This issue will be sorted out before the next version is released.

Regards,

Andrés.


Andrés Maeso
Customer relations manager at Joomla Component Creator.

Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

4 Jahre 6 Tage her #1524 von Andres Maeso

Hi Ruud

Just to follow up on this matter. We have fixed the bug and it will be uploaded as soon as version 3.7 is released.

Regards,

Andrés.


Andrés Maeso
Customer relations manager at Joomla Component Creator.

Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Folgende Benutzer bedankten sich: Ruud van Lent

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

3 Jahre 10 Monate her #1550 von Peter Skarsjo

Could you explain *how* you have fixed it, please? I am way beyond regenerating my component with CC and I will have to carry out the fix myself.
I have already tried a simple rename of the helper class in site. This only results in the class not being found, and the component crashes.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

3 Jahre 10 Monate her #1551 von arnoud van der Reest

I am also way beyond regenerating my component. Please explain how I can Fix this myself.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

3 Jahre 10 Monate her #1557 von Peter Skarsjo

The more I think about this issue, the worse I think it is. I guess it affects *all* your users, i.e. you are in a situation where *all* your users, at least most of them, have crashing components as soon as they upgrade to Joomla 3.7.

I would suggest you issue a warning, by email, to all your users *not* to update their Joomla installation until they have fixed this issue. I also suggest you publish instructions how to fix already generated components. Fixing your own engine is *not* enough.

Those affected by this may find this tip useful. I use a workaround to save the front side at the expense of loosing the admin side. I have renamed the component_name.php in the administrators/helpers directory. This crashes the admin component, but allows the front side to work. If you can manage temporarily without admin service for your component it may help you until CC publish a real fix.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.197 Sekunden
Powered by Kunena Forum

Wir verwenden eigene Cookies und Cookies von Drittanbietern, um Ihr Nutzererlebnis zu verbessern und Ihnen einen optimalen Service zu bieten. Wenn Sie die Website weiter nutzen, gehen wir davon aus, dass Sie mit unserer Cookie-Politik einverstanden sind.